const regex = /\{code\}(.*?)\{code\}/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{code\\}(.*?)\\{code\\}', 'gms')
const str = `{code}
UPDATE tenants SET end_user_uuid = '32392464c8a19a15dd8dc982ae3d574b' WHERE end_user_uuid = '9e194bfeace6c2d17cc71cc15e84f93a' AND instance_id = '265358' AND domain = 'automobieljansen';
{code}`;
const subst = `<pre>$1</pre>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);