// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)\{code\}(.*?)\{code\}").unwrap();
let string = "{code}
UPDATE tenants SET end_user_uuid = '32392464c8a19a15dd8dc982ae3d574b' WHERE end_user_uuid = '9e194bfeace6c2d17cc71cc15e84f93a' AND instance_id = '265358' AND domain = 'automobieljansen';
{code}";
let substitution = "<pre>$1</pre>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}