#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^[ ]{1,})|([ ]{1,}$)"
Local $sString = " E9:F18 M17 M17 X1:H8 " & @CRLF & _
"F105 S34 X1:H8" & @CRLF & _
"F31:X1 Q1:X1 W3 "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)