using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[ ]{1,})|([ ]{1,}$)";
string substitution = @"";
string input = @" E9:F18 M17 M17 X1:H8
F105 S34 X1:H8
F31:X1 Q1:X1 W3 ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}