use strict;
my $str = 'GET /Test?parametr=1 HTTP/1.1
GET /Test HTTP/1.1
GET /Test?parametr=1#Zde HTTP/1.1
GET /Test?parametr1=1¶metr2=2#Zde HTTP/1.1';
my $regex = qr/^(?:GET\s+\/)(?'stranka'.*?)(?:\?(?'parametry'.*?)){0,1}(?:#(?'kapitola'.*?))*(?:\s+HTTP\/.*)$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}