using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^\S]?LUL[\s]?)+$|^([\S]+LUL[\s]?)+$|^[ах]+[\s]*$";
string input = @"LUL LUL LUL LUL
blackufaLUL LUL LUL LUL
blackufaLUL as w qddd
blackufaLUL blackufaLUL
blackufaLUL
blackufaLUL
LUL
blackufaLUL
blackufaLUL blackufaLUL
blackufaLUL
аххахах
ахахах
хааха
страх
страхах
ахахах
фафывафывацуацлжыд жывшапд од lul
lul
^([\S]+LUL[\s]?)+$ - blackufaLUL blackufaLUL
^([^\S]?LUL[\s]?)+$ - LUL LUL LUL
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}