package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^([^\S]?LUL[\s]?)+$|^([\S]+LUL[\s]?)+$|^[ах]+[\s]*$`)
var str = `LUL LUL LUL LUL
blackufaLUL LUL LUL LUL
blackufaLUL as w qddd
blackufaLUL blackufaLUL
blackufaLUL
blackufaLUL
LUL
blackufaLUL
blackufaLUL blackufaLUL
blackufaLUL
аххахах
ахахах
хааха
страх
страхах
ахахах
фафывафывацуацлжыд жывшапд од lul
lul
^([\S]+LUL[\s]?)+$ - blackufaLUL blackufaLUL
^([^\S]?LUL[\s]?)+$ - LUL LUL LUL
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}