import re
regex = re.compile(r"^([^\S]?LUL[\s]?)+$|^([\S]+LUL[\s]?)+$|^[ах]+[\s]*$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("LUL LUL LUL LUL\n"
"blackufaLUL LUL LUL LUL\n"
"blackufaLUL as w qddd \n"
"blackufaLUL blackufaLUL\n"
"blackufaLUL \n"
"blackufaLUL\n"
"LUL \n"
"blackufaLUL\n"
"blackufaLUL blackufaLUL\n"
"blackufaLUL\n"
"аххахах\n"
"ахахах\n"
"хааха\n"
"страх \n"
"страхах\n"
"ахахах \n"
"фафывафывацуацлжыд жывшапд од lul\n"
"lul\n\n\n"
"^([\\S]+LUL[\\s]?)+$ - blackufaLUL blackufaLUL\n"
"^([^\\S]?LUL[\\s]?)+$ - LUL LUL LUL\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")