$re = '/(?:\"[^\"]*\"|\'[^\']*\')(*SKIP)(*F)|\b(and|or)\b/';
$str = 'Industry =\'Education\' or Industry ="Energy" or Industry = \'Financial or Bank\' or Industry = \'Hospitality\' or Industry = "Food and Beverage" and Industry = \'Utilities\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);