package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)mp4="(?<video_url>[^"]+)"`)
var str = `mp4="https://example.com/wp-content/uploads/2023/11/file_example-MP4-480_1_5MG.mp4"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}