const regex = /mp4="(?<video_url>[^"]+)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('mp4="(?<video_url>[^"]+)"', 'gm')
const str = `mp4="https://example.com/wp-content/uploads/2023/11/file_example-MP4-480_1_5MG.mp4"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}