#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^.. |^... |^.... )([^,]*,[^,:]*)"
Local $sString = "46. Delmay, B.: I personaggi della Divina Commedia. Volume 201. Olschki (1986)" & @CRLF & _
"129. Kurucz, R.: Atlas9 stellar atmosphere programs and 2 km/s grid. ATLAS9 Stellar Atmosphere Programs and 2 km/s grid. Kurucz CD-ROM No. 13. Cambridge, Mass.: Smithsonian Astrophysical Observatory, 1993. 13 (1993)" & @CRLF & _
"130. Andrewes, D.G., Holton, J.R., Leovy, C.B.: Middle atmosphere dynamics. Number 40. Academic press (1987)" & @CRLF & _
"6. Welch, T.A.: A technique for high-performance data compression. Computer 17(6) (1984) 8–19" & @CRLF & _
"47. Alighieri, D., Landino, C., da Figino, P., Capcasa, M.: La divina commedia. G. Silvestri (1829)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")