using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^.. |^... |^.... )([^,]*,[^,:]*)";
string input = @"46. Delmay, B.: I personaggi della Divina Commedia. Volume 201. Olschki (1986)
129. Kurucz, R.: Atlas9 stellar atmosphere programs and 2 km/s grid. ATLAS9 Stellar Atmosphere Programs and 2 km/s grid. Kurucz CD-ROM No. 13. Cambridge, Mass.: Smithsonian Astrophysical Observatory, 1993. 13 (1993)
130. Andrewes, D.G., Holton, J.R., Leovy, C.B.: Middle atmosphere dynamics. Number 40. Academic press (1987)
6. Welch, T.A.: A technique for high-performance data compression. Computer 17(6) (1984) 8–19
47. Alighieri, D., Landino, C., da Figino, P., Capcasa, M.: La divina commedia. G. Silvestri (1829)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}