re = /(^\d{3,5}$)|(^E\d{3,4}$)|(^V\d{2,4}$)/m
str = '11111
2222
999
E123
E1234
V12
V123
V1234
11
111111
11a11
1a1
E12
E12345
V1
V123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end