// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^\d{3,5}$)|(^E\d{3,4}$)|(^V\d{2,4}$)").unwrap();
let string = "11111
2222
999
E123
E1234
V12
V123
V1234
11
111111
11a11
1a1
E12
E12345
V1
V123
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}