const regex = /^(a);(.*?);(.*?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(a);(.*?);(.*?)$', 'gm')
const str = `a;b;c
a;x;23
b;b;12`;
const subst = `\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);