package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[Oo]rgani.e$|^[Oo]rgani.e\w$`)
var str = `organise
Organi1e
Organizer
organifed`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}