package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"[^\n"]*?\bhello\b[^\n"]*"|(\bhello\b)`)
var str = `"hello"
"testing... hello world"
hello
"hello
hello"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}