import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"[^\\n\"]*?\\bhello\\b[^\\n\"]*\"|(\\bhello\\b)";
final String string = "\"hello\"\n"
+ "\"testing... hello world\"\n"
+ "hello\n"
+ "\"hello\n"
+ "hello\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}