import Foundation
let pattern = #"(\/\/[^"\n\r]*(?:"[^"\n\r]*"[^"\n\r]*)*[\r\n]|\/\*([^*]|\*(?!\/))*?\*\/)(?=[^"]*(?:"[^"]*"[^"]*)*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
hey = "//comment" //comment "
hey = "//comment" //comment
hey = "/" //comment"
//
"//"/"
# complete line should be found
//comment
lorem ipsum # from this to line end
/*
all three lines should be found
*/ but not here anymore
var x = \\"this # should not be found\\"
var y = \\"this /* shouldn\\'t */ match either\\"
var z = \\"but\\" & /* this must match */ \\"_\\"
Argh! what about a \\"multiline string\\\\
with a # mark\\\\
int it ?! \\"
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)