#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[^*\n]*\*){2}([^*\n]*)"
Local $sString = "LLC1R.8888.GR0054656*DR.798012...2..............GR0054656*CNY*ARTIST*" & @CRLF & _
"TC1R.88.GR0054656*DR.765012...2..............GR0054656*EUR*LUKE*" & @CRLF & _
"K56R.8.GR0054656*DR.258812...4..............GR0054656*AUD*" & @CRLF & _
"790GG.88.GR0054656*DR.338012...5..............GR0054656*IDR*MATTHEW*" & @CRLF & _
"GREFD.888.GR0054656*DR.198012...6..............GR0054656*"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")