# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[^*\n]*\*){2}([^*\n]*)"
test_str = ("LLC1R.8888.GR0054656*DR.798012...2..............GR0054656*CNY*ARTIST*\n"
"TC1R.88.GR0054656*DR.765012...2..............GR0054656*EUR*LUKE*\n"
"K56R.8.GR0054656*DR.258812...4..............GR0054656*AUD*\n"
"790GG.88.GR0054656*DR.338012...5..............GR0054656*IDR*MATTHEW*\n"
"GREFD.888.GR0054656*DR.198012...6..............GR0054656*")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.