package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)23[^.]*c`)
var str = `1a.10.2a.210.22ac.23acd.24acd
1a.10.2a.210.22ac.23axd.24acd
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}