import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^START\\b.*(?:\\R(?!START\\b|END_OF_MSG\\b).*)*";
final String string = "HELLO\n"
+ "START ABC DEF GHI JKL\n"
+ "QWER RANDOM TEXT 213%@#!\n"
+ "UIOP RANDOMZXCVB123456\n"
+ "START ABC DEF GHI JKL\n"
+ "ZZZZZ RANDOMTEXT213%@#!\n"
+ "11111 RANDOMZXCVB123456\n"
+ "$$$$$$ SOMEMORETEXT\n"
+ "START ABC DEF GHI JKL\n"
+ "QWER RANDOMTEXT213%@#!\n"
+ "$$$$$ RANDOMZXCVB123456\n"
+ "END_OF_MSG";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}