$re = '/^(\w+)\s(\d+)(.*(?:\r?\n(?!\w+\s\d).*)*)/m';
$str = 'Abc 123 def
ghi
jkl
Abc 123 def ghi jkl mno
Abc 123 def ghi jkl
mno';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);