# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.gif\?([^=]+=[^=]+&)+[^=]+(=[^=]+)?"/.gif"/gm;t' <<< "
<img src=\"https://media.giphy.com/media/m7jzopL8Dm1kA/giphy.gif?cid=ecf05e4785d70ac4724a4083945ea6171d95688bf6a8a282&rid=giphy.gif&ct=g\"  /> "