#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\.gif\?([^=]+=[^=]+&)+[^=]+(=[^=]+)?""
Local $sString = "" & @CRLF & _
                "<img src="https://media.giphy.com/media/m7jzopL8Dm1kA/giphy.gif?cid=ecf05e4785d70ac4724a4083945ea6171d95688bf6a8a282&rid=giphy.gif&ct=g"  /> "
Local $sSubst = ".gif""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)