using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.gif\?([^=]+=[^=]+&)+[^=]+(=[^=]+)?""";
string substitution = @".gif""";
string input = @"
<img src=""https://media.giphy.com/media/m7jzopL8Dm1kA/giphy.gif?cid=ecf05e4785d70ac4724a4083945ea6171d95688bf6a8a282&rid=giphy.gif&ct=g"" /> ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}