import Foundation
let pattern = #"\.gif\?([^=]+=[^=]+&)+[^=]+(=[^=]+)?""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<img src="https://media.giphy.com/media/m7jzopL8Dm1kA/giphy.gif?cid=ecf05e4785d70ac4724a4083945ea6171d95688bf6a8a282&rid=giphy.gif&ct=g" />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #".gif""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)