re = /^yellow_y\s+\K\S+/m
str = 'yellow abc \\
yellow_x abc \\
yellow_y acc \\
blue abb \\
pink abb \\
pink_xx acd \\'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end