re = /;\s*/m
str = '51.9499, 7.555780000000027; 51.49705, 9.389030000000048; 51.249182, 6.991165099999989; 47.3163508, 11.09513949999996; 51.33424979999999, 12.574196000000029; 50.0297493, 19.196331099999952; 47.8270212, 16.25014150000004; '
subst = ';\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result