#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^LIN[\s\S]*^DTM.*"
Local $sString = "UNB+UNOC:3+O0013001550GDID0000Z6H:14+80585:14+200218:1455+8' " & @CRLF & _
"UNH+1+ORDERS:D:96B:UN' " & @CRLF & _
"BGM+120+4016026958' " & @CRLF & _
"DTM+4:20200218:102' " & @CRLF & _
"NAD+BY+437750' " & @CRLF & _
"NAD+SU+0000080585' " & @CRLF & _
"NAD+OB+0000080585' " & @CRLF & _
"NAD+DP+4000::9++Cronus Company:Cronus GmbH & Co. KG+Musterstrasse 3+Kirchdorf++12345+DE' " & @CRLF & _
"CUX+2:EUR' " & @CRLF & _
"TOD+6++DAP' " & @CRLF & _
"LIN+00010++079790040080030:SA' " & @CRLF & _
"PIA+1+079790040080030:SA' " & @CRLF & _
"IMD+F++:::DIN 7979 D Stahl blank | 8x30 Zylin' " & @CRLF & _
"QTY+12:10,000:PCE' " & @CRLF & _
"PRI+AAA:23,56:::100:PCE' " & @CRLF & _
"SCC+1' " & @CRLF & _
"QTY+1:10,000' " & @CRLF & _
"DTM+2:20200223:102' " & @CRLF & _
"LIN+00020++079790040080040:SA' " & @CRLF & _
"PIA+1+079790040080040:SA' " & @CRLF & _
"IMD+F++:::DIN 7979 D Stahl blank | 8x40 Zylin' " & @CRLF & _
"QTY+12:10,000:PCE' " & @CRLF & _
"PRI+AAA:24,58:::100:PCE' " & @CRLF & _
"SCC+1' " & @CRLF & _
"QTY+1:10,000' " & @CRLF & _
"DTM+2:20200223:102' " & @CRLF & _
"LIN+00030++009128009060016:SA' " & @CRLF & _
"PIA+1+009128009060016:SA' " & @CRLF & _
"IMD+F++:::DIN 912 Stahl 8.8 blank | M6x16 Zyl' " & @CRLF & _
"QTY+12:100,000:PCE' " & @CRLF & _
"PRI+AAA:2,36:::100:PCE' " & @CRLF & _
"SCC+1' " & @CRLF & _
"QTY+1:100,000' " & @CRLF & _
"DTM+2:20200223:102' " & @CRLF & _
"UNS+S' " & @CRLF & _
"UNT+35+1' " & @CRLF & _
"UNZ+1+8' " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")