using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?x)
(?<=<td>)[^<>]+";
string input = @"<table style=""width:100%"">
<tr>
<th>FirstName</th>
<th>LastName</th>
<th>Age</th>
</tr>
<td>Jill</td>
<td>Nigam</td>
<td>25</td>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}