$re = '/[^\/]+(?=\.\w+$)\.\w+$/m';
$str = 'https://cdn.nlark.com/yuque/0/2024/png/184438/1725935789441-7fcfe714-3a05-40d8-90b5-62a21ea95695.png
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);