package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(generic:(?<Field>[^\)]*)\)\(`)
var str = `String = This is the string (generic:ggmail.com)(3245612)
= This is the string (generic:abcdexadsfsdf.cc)(1232143)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}