package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`href=[\'\"]?([^\'\" >]+)`)
var str = `"<li><a>href=http://w...content-available-to-author-only...f.br/cdara/sisu-2/sisu-2017-1a-edicao/lista-de-espera-sisu-3/?id_curso=01GV&id_grupo=70>ADMINISTRAÇÃO - GOVERNADOR VALADARES - DIURNO - SISU - GRUPO A</a></li><li><a href=http://w...content-available-to-author-only...f.br/cdara/sisu-2/sisu-2017-1a-edicao/lista-de-espera-sisu-3/?id_curso=01GV&id_grupo=71>ADMINISTRAÇÃO - GOVERNADOR VALADARES - DIURNO - SISU - GRUPO B</a></li>"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}