use strict;
my $str = '[[:fr:Mille_Miglia_1932|Mille Miglia]]
[[:fr:wikt:demi-produit|demi-produit]] :
Amours Gauquié Pont Alexandre III Paris.jpg|Lampadaire "Ronde des Amours" de [[:fr:Henri Désiré Gauquié|Henri Désiré Gauquié]], [[Pont Alexandre III]] Kiosque...
- * [[:fr:Jean Dewasne|Jean Dewasne]]
';
my $regex = qr/\[\[:fr:(?P<lien>[^:|[{}\n\]\|]+)\|(?P=lien)\]\]/mp;
my $subst = '[[\\g<1>]]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";