#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b([a-zA-Z][\w\d-]+)"
Local $sString = "black PENS Assorted Bit Set 10Pcs " & @CRLF & _
"Hollow blocks 10-16mm Cd3 " & @CRLF & _
"Hollow blocks 16-23mm Cd3 " & @CRLF & _
"Hollow blocks 5-10mm Cd3 " & @CRLF & _
"Hollow blocks To 1-5mm Cd3-333 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")