using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s{4}\/\*\*\n\s+\*\s@see\s[a-zA-Z\.#\(,\*\s\)]+\*\/";
string input = @" /**
* @see duke.webapp.struts.DukeDispatchAction#executeDefault(org.apache.struts.action.ActionMapping,
* org.apache.struts.action.ActionForm, javax.servlet.http.HttpServletRequest,
* javax.servlet.http.HttpServletResponse)
*/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}