using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"7PTC[\w\d]{4}";
string input = @"7PTC69RT 7PTC67KM 7PTC689F";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}