import Foundation
let pattern = #"<code(?:\s+type=(?:"([^"]+)"|\'([^\']+)|(\w+)))?>(.*?)<\/code>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"Hallo das sind Code Tags: <code>das ist ein code tag</code> oder das <code type="php">echo "Hallo Welt!";</code> oder <code type=html> <h1>Willkommen!</h1> </code>. Danke."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)