$re = '~(http://example.com/images/.*?/.*?/.*?).png~';
$str = 'http://example.com/images/XX/YY/filename.png';
$subst = "$1.jpg";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;