using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{8}$)(?:(?:[a-z]+|[0-9]+)(?:-|$)){3}";
string input = @"aa-99-99
99-23-bd
02-xx-04
ab-99-cz
sc-xd-49
99-xav-4
48-xyz-09
9-abc-01
xs-899-x
sss-99-x
10-b1-c2
aa-bb-01
10-11-ac";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}