use strict;
my $str = '<div>
<iframe src="https://youtube.com"></iframe>
<iframe src="http://www.youtube.com"></iframe>
<iframe class="test" src="http://youtu.be/123"></iframe>
<iframe src="https://yoursite-is-safe-from-gdpr.com"></iframe>
</div>';
my $regex = qr/<iframe.+src="https?:\/\/(?:www.)?youtu\.?be(?:\.com)?.+<\/iframe>/mip;
my $subst = '<div>You must accept cookies before seeing this video content</div>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";