// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(\d+[A-Z]+)(\d+[-; ]+)(\d+\b)").unwrap();
let string = "987ABC11-15; 77; 877; 66-68
987ABC11-987ABC15; 77; 877; 66-68
987ABC11-987ABC15; 987ABC77; 877; 66-68
987ABC11-987ABC15; 987ABC77; 987ABC877; 66-68
987ABC11-987ABC15; 987ABC77; 987ABC877; 987ABC66-68
987ABC11-987ABC15; 987ABC77; 987ABC877; 987ABC66-987ABC68";
let substitution = "$1$2$1$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}