import re
regex = re.compile(r"(?P<dup>(\w+\s+))(?P=dup)", flags=re.MULTILINE)
test_str = ("#命名表达式,并反向引用。比如查找重词\n"
"1 hello hello \n"
"2 hello world\n"
"3 妮妮好\n"
"4 你 你 \n"
"5 wo wo \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")