use strict;
my $str = 'A1../D//FASDFAS--DFASD//.F';
my $regex = qr/(\G(?!^|(?:[0-9A-Za-z][^0-9A-Za-z]*){2}$)|^(?:[^0-9A-Za-z]*[0-9A-Za-z]){5})./mp;
my $subst = '$1*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";