re = /(\G(?!^|(?:[0-9A-Za-z][^0-9A-Za-z]*){2}$)|^(?:[^0-9A-Za-z]*[0-9A-Za-z]){5})./m
str = 'A1../D//FASDFAS--DFASD//.F'
subst = '$1*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result