re = /(?<!BM\.)(?<=\W)Draw(Image|Text)\s*([^\;\n]+)(\;|$)/m
str = ' BM.DrawImage(GameOverImg,MW-ImageWidth(GameOverImg) , MH-ImageHeight(GameOverImg));
gotxt=GetTextLine(60);
break;
case 0: // если пориграли
BM.SetColor(255,0,0);
DrawImage GameOverImg,MW-ImageWidth(GameOverImg) , MH-ImageHeight(GameOverImg);
DrawText string gotxt,MW-TextWidth(gotxt)/2 , MH-TextHeight(gotxt)/2'
subst = 'BM.Draw$1($2)$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result