import Foundation
let pattern = #"(?<!BM\.)(?<=\W)Draw(Image|Text)\s*([^\;\n]+)(\;|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
BM.DrawImage(GameOverImg,MW-ImageWidth(GameOverImg) , MH-ImageHeight(GameOverImg));
gotxt=GetTextLine(60);
break;
case 0: // если пориграли
BM.SetColor(255,0,0);
DrawImage GameOverImg,MW-ImageWidth(GameOverImg) , MH-ImageHeight(GameOverImg);
DrawText string gotxt,MW-TextWidth(gotxt)/2 , MH-TextHeight(gotxt)/2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"BM.Draw$1($2)$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)